The Slim Framework support forum has moved to http://discourse.slimframework.com. This Tender forum is no longer maintained or monitored.

Slim 3.1 beginning

Thomas Mueller's Avatar

Thomas Mueller

23 Feb, 2016 07:05 PM

Good evening,
i want to use the slim framework, but i'm unable to get this framework running.

I don't want to use the composer, because the newest version is 3.0.1.
But on slimframework.com the newest version is 3.1.
So i downloaded the zip where i only have the slim folder with its subfolders ans files.

When i try to run this framework described in user guide, it fails.
Apache Error: Class Slim/App not found.

Here is my index (copied from slimframework user guide):
<?php
// Create and configure Slim app
$app = new \Slim\App; // <--- Error

// Define app routes
$app->get('/{name}', function ($request, $response, $args) {
    return $response->write("Hello " . $args['name']);
});

// Run app
$app->run();

So whats the problem?
Maybe the user guide is incomplete?

I also have no autoload.php (i think only if you use composer) or slim.php (only in version 2?).
So how i do include the slimframework in my index.php?

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac