The Slim Framework support forum has moved to http://discourse.slimframework.com. This Tender forum is no longer maintained or monitored.

PHPSESSID in response header.

girikyasanur's Avatar

girikyasanur

16 Jul, 2012 01:02 PM

Hi,
I am new to Slim Framework. Just started couple of days back.
For every RESTful request, I am getting PHPSESSID in the header.

"Set-Cookie: PHPSESSID=nftrcev812pvqpudqwe5acp7t0; path=/; HttpOnly"

Is there any way to delete/hide this? I dont want to show that to the client.

Thanks in advance.
Girish

  1. Support Staff 1 Posted by Brian Nesbitt on 16 Jul, 2012 04:44 PM

    Brian Nesbitt's Avatar

    Assuming you are not using sessions specifically? Calling session_start() ?

    I'd ask about using Slim secure sessions or flash (which is stored in the session) but the default slim session variable is slim_session so doubt thats it.

    There is a php.ini setting called session.auto_start. You can read about it here http://php.net/session.auto-start Maybe you have that turned on so the PHP engine is actually auto starting the session.

    Let us know and if thats not it we can maybe dig a little deeper.

  2. 2 Posted by girikyasanur on 17 Jul, 2012 09:37 AM

    girikyasanur's Avatar

    Thanks for the quick response.
    Yes session_start() is used here.
    We have a web application and session_start() is part of that. And we are working on an API (using Slim). There are many functions common to both web app and the API. I will make sure that the session part will not be included in API part.

    Thanks,
    Girish

  3. girikyasanur closed this discussion on 17 Jul, 2012 09:37 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac