The Slim Framework support forum has moved to http://discourse.slimframework.com. This Tender forum is no longer maintained or monitored.

DELETE verb supported?

Brent Clements's Avatar

Brent Clements

18 Apr, 2012 03:37 PM

Running under apache.

I was curious if I'm just doing something wrong by not configuring slim or not.

I have a $app->delete route action. But when I run curl against the uri route, I get the following error

HTTP method not allowed for the requested resource. Use one of these instead: POST

Am I doing something wrong with slim itself? I thought apache supported DELETE.

Thanks for any help!

  1. Support Staff 1 Posted by Josh Lockhart on 18 Apr, 2012 04:02 PM

    Josh Lockhart's Avatar

    Can you post the relevant Slim application code, and the exact command line curl command you are running?

  2. Support Staff 2 Posted by Josh Lockhart on 27 Jul, 2012 03:21 PM

    Josh Lockhart's Avatar

    Hmm... you should inspect the raw HTTP request to ensure the request method and headers are exactly as you expect. I prefer Chrome's Webkit Inspector, but there are other tools available. Can you post the raw request?

  3. 3 Posted by boudewijng on 27 Jul, 2012 03:27 PM

    boudewijng's Avatar

    Never mind. I made a stupid mistake. I was calling the wrong url. It works now. Thanks for the quick tho!

  4. Support Staff 4 Posted by Josh Lockhart on 27 Jul, 2012 03:27 PM

    Josh Lockhart's Avatar

    Great! Glad you got it resolved. Closing this out.

  5. Josh Lockhart closed this discussion on 27 Jul, 2012 03:27 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac